Installation
Welche Systemvoraussetzung sind für die Installation von PAT notwendig?
Unterstützte Betriebssysteme
- Windows 7 Professional mit Service Pack 1 (32- und 64-Bit-Versionen)
- Windows 8 und 8.1 Professional (32- und 64-Bit-Versionen) für die Bedienung mit Maus und Tastatur
- Windows Server 2008 R2 (32- und 64-Bit-Versionen)
- Windows Server 2012 R2 (32- und 64-Bit-Versionen)
Prozessor
- 32-Bit-Prozessor 1,5 GHz oder schneller (x86) Prozessor
- 64-Bit-Prozessor 1,5 GHz oder schneller (x64)
- empfohlen: Intel Core i5 oder AMD Athlon II x2 (oder neuer)
Speicher
- mindestens: 4 GB RAM
- empfohlen: 16 GB RAM
Grafikeinheit
- DirectX 9-kompatible Grafikkarte mit WDDM 1.0
- mindestens 1280 x 800 Pixel Bildschirmauflösung
Freier Festplattenspeicherplatz
- maximal 2 GB bei MS Access
- maximal 10 GB bei MS SQL Server 2008 R2 Express SP2
- praktisch unbegrenzt bei MS SQL Server 2008 – 2012
benötigte Software
- Datenquelle (MS SQL Server, MS Access, Textdatei), ist kein MS SQL Server vorhanden, wird (optional) eine MS SQL Server 2008 R2 Express SP2 Instanz installiert.
- MS SQL Server Management Studio (wird optional installiert).
- Für die Bearbeitung von Exportdateien im Excel-Format wird die entsprechende kostenpflichtige MS Office Komponente benötigt.
Welches Datenbankmanagementsystem wird benötigt?
Es wird mindestens der MS SQL Server 2008 R2 Express SP2 vorausgesetzt.
Lauffähig ist die Software aber auch mit allen neueren Versionen des SQL-Servers. Bei der automatischen Installation wird eine neue MS SQL Server 2008 R2 Express SP2 - Instanz mitinstalliert.
Anlagenkonfiguration
Welche Datenquellen werden derzeit unterstützt?
Folgende Datenquellen unterstützt PAT:
- Priva-History (MS SQL)
- Priva-History (Access)
- CSV (Format ist frei definierbar)
- Excel (Format ist frei definierbar)
- Priva-XML (Für den Meldungsimport)
Beim Zugriff auf die Priva-History-Daten wird zudem die Low/High-Byte-Trennung unterstützt.
Der Zugriff auf die Priva-Daten erfolgt direkt, d.h. ohne Zwischenspeicherung. Bei CSV oder Excel als Datenquelle wird ein Import in die PAT-Datenbank durchgeführt
Wie können viele Messreihen effektiv angelegt werden?
Ist eine Priva-Anlage konfiguriert, dann können die verfügbaren Messreihen automatisch anhand der Priva-Konfiguration importiert werden:

Um die Übersicht zu behalten, werden bereits importierte Messreihen grün hinterlegt.
Fehlerbehebung
Beim Zugriff auf Access erscheint die Fehlermeldung "unable to load odbcji32.dll". Wie kann dieser Fehler behoben werden?
Einige Windows-Updates können unter Windows 10 dazu führen, dass die "Access DB-Engine" nicht mehr richtig funktioniert.
Eine Neuinstallation der "Microsoft Access Database Engine 2010" von
https://www.microsoft.com/de-DE/download/confirmation.aspx?id=13255
behebt den Fehler.
Nach einer erfolgreichen Anmeldung wird eine Warnmeldung angezeigt!
Die Meldung wird durch den PAT-Service ausgelöst. Nach einem fehlerfreien Programmstart bestätigen Sie die Meldung mit Nein.
Beim Zugriff auf Access erscheint die Fehlermeldung "Allgemeiner Fehler Der Registrierungsschlüssel ..."
Beim Zugriff auf Access erscheint diese Fehlermeldung:

Der Fehler ist auf eine fehlende Berechtigung auf den ODBC-Registrierungsschlüssel zurückzuführen. Führen Sie zur Behebung die folgenden Schritte aus:
- Starten Sie den Registrierungseditor (Regedt32.exe).
- Markieren Sie folgenden Schlüssel in der Registrierung:
HKEY_LOCAL_MACHINE\SOFTWARE\ODBC
- Klicken Sie im Menü Sicherheit auf Berechtigungen.
- Geben Sie die erforderlichen Berechtigungen für das Konto ein, das auf die Webseite zugreift.
- Beenden Sie den Registrierungseditor.
Automatisierung
Was muss beim Starten des PAT-Service beachtet werden?
Der PAT-Service wird zur Automatisierung der Berichtserstellung, aber auch für den Datenimport und die REST-Schnittstelle benötigt.
Hierbei handelt es sich um einen Windows-Service der im Hintergrund ausgeführt wird. Wichtig hierbei ist, dass dieser Service für einen Windows-Benutzer ausgeführt wird, der alle benötigten Zugriffsberechtigungen besitzt.
Hierzu gibt es im Dialog "Automatisierung" 2 Buttons zum Starten und Stoppen des Services:

Wichtig ist, dass PAT mit Administratorrechten gestartet wird. Sonst hat das Programm keinen Zugriff auf die Windows-Serviceverwaltung.
Manchmal funktioniert der Start des PAT-Service mittels dieser Buttons nicht. Dann können die im Programmpfad vorhandenen Dateien "start.bat" und "stop.bar" verwendet werden.
Auch hier muss der Start mittels Administratorrechten erfolgen (Rechte Maustaste + "Als Administrator ausführen").